CHSSWeb Help
College of Humanities and Social Sciences

Browsers

Please be sure you are using an up-to-date browser. If you are prevented from updating your browser for some reason, we recommend that you install another browser on your system and use that as your primary tool not just for browsing the CHSSWeb tools, but also for browsing the Internet in general. Aside from site rendering problems you may encounter when using an old browser, using an old browser version is a bad security risk and may lead to your computer being compromised.

The CHSSWeb tools support up-to-date versions of most browsers including:

  • Safari
  • Chrome
  • Firefox

We do not recommend the most recent version of Internet Explorer. Some portions of the tools may be problematic in that browser.

This advice applies only to the CHSSWeb dashboard and other tools. We make every effort to test the public pages generated by CHSSWeb in multiple browsers and to have those pages degrade gracefully in older browsers.

Print Friendly and PDF